UGENE-git

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
custom-tool-config-dir

custom-tool-config-dir

custom-element-script-dir

custom-element-script-dir

custom-element-external-tool-dir

custom-element-external-tool-dir

"elemets" <- a typo.

"elemets" <- a typo.

AppSettings is not initialized yet.

AppSettings is not initialized yet.

AppSettings is not initialized yet.

AppSettings is not initialized yet.

It should work for the first branch too. Move it outside if.

It should work for the first branch too. Move it outside if.

All these parameters processing should be in either ugeneui/main.cpp and plugin_checker/main.cpp as well.

All these parameters processing should be in either ugeneui/main.cpp and plugin_checker/main.cpp as well.

There is no possibility to set the working dir. Add it.

There is no possibility to set the working dir. Add it.

Several constructions like if (hasParameter) { setParameter(); } look better than cycle. Maybe it is better to extract this code to a separate method, since it was enlarged?

Several constructions like

if (hasParameter) {
    setParameter();
}

look better than cycle.
Maybe it is better to extract this code to a separate method, since it was enlarged?

Some of values have "path", some of them don't. I offer to remove "path" from values that have it, because some old values don't have it.

Some of values have "path", some of them don't. I offer to remove "path" from values that have it, because some old values don't have it.

These variables belong to Workflow Designer. Move them to the WorkflowDesignerPlugin class. Process them in WorkflowDesignerPlugin::processCMDLineOptions method.

These variables belong to Workflow Designer. Move them to the WorkflowDesignerPlugin class. Process them in WorkflowDesignerPlugin::processCMDLineOptions method.

It is "Directory for custom elements with external tools" in the Application Settings dialog. Rename the variable and change its value to be more clear.

It is "Directory for custom elements with external tools" in the Application Settings dialog. Rename the variable and change its value to be more clear.

It is "Directory for custom elements with scripts" in the Application Settings dialog. Rename the variable and change its value to be more clear.

It is "Directory for custom elements with scripts" in the Application Settings dialog. Rename the variable and change its value to be more clear.

"dr" <- a typo.

"dr" <- a typo.

UTI-330 - arguments to set some paths
UTI-330 - arguments to set some paths
Remove "_" from the header file only. Also rename sequencesToAlignIds to rowsToAlignIds.

Remove "_" from the header file only.
Also rename sequencesToAlignIds to rowsToAlignIds.

realigntask - use camel case.

realigntask - use camel case.

Because updateActions() called at the end of constructor and it need initialized realignSomeSequenceAction.

Because updateActions() called at the end of constructor and it need initialized realignSomeSequenceAction.

I'm not quite sure that this file is required to be changed.

I'm not quite sure that this file is required to be changed.

and locker = nullptr;

and

locker = nullptr;
So, why some of actions could be added in MSAEditor::createWidget() and some of them should be created in constructor?

So, why some of actions could be added in MSAEditor::createWidget() and some of them should be created in constructor?

Something with the indent

Something with the indent

No need to check stateInfo

No need to check stateInfo

Rename "rowsToAlignId" to" _rowsToAlignId"

Rename "rowsToAlignId" to" _rowsToAlignId"

Rename "sequenceIndexesToRealign" to" _sequenceIndexesToRealign"

Rename "sequenceIndexesToRealign" to" _sequenceIndexesToRealign"