Denis Kandrov

Ok, I understood you. Print it for every subproject is really weird.

Ok, I understood you. Print it for every subproject is really weird.

Maybe we should uncomment this message?

Maybe we should uncomment this message?

Maybe we should uncomment this message?

Maybe we should uncomment this message?

TODO!

TODO!

Why definition and declaration are not in one line, but on neighbour lines?

Why definition and declaration are not in one line, but on neighbour lines?

To remove.

To remove.

Looks like all javascript files use string concatenation, so it is doesn't matter in this review.

Looks like all javascript files use string concatenation, so it is doesn't matter in this review.

Note: menuLine.insertAdjacentHTML('beforeend', hintDef.outerHTML);

Note:

        menuLine.insertAdjacentHTML('beforeend', hintDef.outerHTML);
But the right solution I think should be to add this part of the code to HTML layout and only show/hide it when it is necessary.

But the right solution I think should be to add this part of the code to HTML layout and only show/hide it when it is necessary.

This is the same solution with using jQuery: https://jsfiddle.net/y8gzsawc/

This is the same solution with using jQuery: https://jsfiddle.net/y8gzsawc/

Maybe will be better to use the creating of DOM elements instead of the string concatenation. Something like this: var hintContainer = document.createElement('div'); hintContainer.id = 'load-btn-h...

Maybe will be better to use the creating of DOM elements instead of the string concatenation.
Something like this:

var hintContainer = document.createElement('div');
 hintContainer.id = 'load-btn-hint-container';
 var hintButton = document.createElement('div');
 hintButton.id = 'load-btn-hint'
 hintButton.className =  'popover fade bottom in';
 hintButton.style = 'display: block';
 var arrow = document.createElement('div');
 arrow.className = 'arrow';
 arrow.style = 'left: 91%';
 var popoverContent = document.createElement('div');
 popoverContent.className = 'popover-content';
 var enContent = document.createElement('span');
 enContent.className = 'translatable';
 enContent.setAttribute('lang','en');
 enContent.innerHTML = "You can always open the original workflow for your results by clicking on this button.";
 var ruContent = enContent.cloneNode();
 ruContent.setAttribute('lang','ru');
 ruContent.innerHTML = "?? ?????? ?????? ??????? ???????? ?????????????? ????? ??? ????? ???????????, ????? ?? ??? ??????.";
 var gotItButtonDiv = document.createElement('div');
 gotItButtonDiv.style = 'text-align: center;';
 var gotItButton = document.createElement('button');
 gotItButton.className = 'btn';
 gotItButton.setAttribute('onclick','agent.hideLoadButtonHint()');
 gotItButton.style = 'margin-bottom: 4px; margin-top: 6px;';
 enGotItButtonText = enContent.cloneNode();
 enGotItButtonText.innerHTML = "OK, got it!";
 ruGotItButtonText = ruContent.cloneNode();
 ruGotItButtonText.innerHTML = "??????!";
 //Build hint
 hintContainer.appendChild(hintButton);
 hintButton.appendChild(arrow);
 hintButton.appendChild(popoverContent);
 popoverContent.appendChild(enContent);
 popoverContent.appendChild(ruContent);
 popoverContent.appendChild(gotItButtonDiv);
 gotItButtonDiv.appendChild(gotItButton);
 gotItButton.appendChild(enGotItButtonText);
 gotItButton.appendChild(ruGotItButtonText);

Sample is here: https://jsfiddle.net/byxezrsn/2/

But I'm not sure. Maybe exists better solution.

Perhaps it should be in Common.js.

Perhaps it should be in Common.js.

You can replace the absolute path with some named variable. Something like $MYSQL_LIB_PATH.

You can replace the absolute path with some named variable. Something like $MYSQL_LIB_PATH.

And also rename method to 'isAlphabetTypeSupported'

And also rename method to 'isAlphabetTypeSupported'

Rename 'alphabet' to 'alphabetType'

Rename 'alphabet' to 'alphabetType'

UGENE-5471 fix quality type detection and saving quality info

UGENE-5471 Fix review comments

UGENE-5471 Change quality type detection mechanism

UGENE-5471 fix quality type detection and saving quality info
UGENE-5471 fix quality type detection and saving quality info
UGENE-5471 fix quality type detection and saving quality info

Don't forget read and fix my comments from previous review: REVIEW-1200

Don't forget read and fix my comments from previous review: REVIEW-1200

Unused variable. Remove it.

Unused variable. Remove it.

Remove extra empty string.

Remove extra empty string.

Rename parameter 'alphabetType' to 'supportedAlphabets' as in the ancestor class.

Rename parameter 'alphabetType' to 'supportedAlphabets' as in the ancestor class.