UGENE
  1. UGENE
  2. UGENE-6544

"Search field" in the SV is not updated when "Search with ambiguous bases" is checked

    Details

    • Story Points:
      3
    • Affect Type:
      Userdefined

      Description

      Scenario:

      1. Open a DNA sequence in the SV.
      2. Open the "Search in Sequence" tab on the options panel.
      3. Set algorithm to "Substitute" in the "Search algorithm" group.
      4. Input a pattern that contains a character of the extended DNA alphabet, e.g. "ACWT".
        Expected/current result: the search field background is red. There is a message below:
        Warning: input value contains characters that do not match the active alphabet!
        
      5. Make the "Search with ambiguous bases" option checked.
        Expected result: the search field should have white background, the warning message should disappear.
        Current result: nothing happens.

      Note that the tab appearance is updated, if you e.g. input a space character smth into the search field.

        Issue Links

          Activity

          Hide
          Dmitrii Sukhomlinov
          added a comment -

          The GUI test is required

          Show
          Dmitrii Sukhomlinov
          added a comment - The GUI test is required

            People

            • Assignee:
              Yuliya Algaer
              Reporter:
              Olga Golosova
              Assigned Tester:
              Dmitrii Sukhomlinov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: