UGENE
  1. UGENE
  2. UGENE-6574

Support non-ASCII character when aligning a sequence to an alignment

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.32
    • Fix Version/s: 34
    • Component/s: Basic-MSA
    • Labels:
    • Sprint:
      DEV-34-1
    • Affect Type:
      Userdefined

      Description

      Scenario:

      1. Make sure MAFFT external tool is set up.
      2. Open an alignment that contains a sequence with name that has non-ASCII characters (e.g. Russian).
      3. Click "Align sequence to this alignment" button on the toolbar and select some appropriate sequence.
        Expected result: the sequence has been aligned to the alignment.
        Current result: an error occurs, the following notification is pop up:
        'Align sequences to alignment task' task failed: Subtask {Align sequences to alignment task} is failed: Document is empty.
        

        In the "TRACE" category of the log there may be messages like:

        MAFFT: Distance 0-230 is strange, 13.304991.
        

      The sequences should be temporarily renames when MAFFT is run. Note that a similar feature is used when multiple sequence alignment is done.

      Check also other tasks: pairwise alignment, building a tree, etc.

        Issue Links

          Activity

          Olga Golosova
          added a comment - - edited

          The feature works properly, the problems happened because of another reason - a sequence contain only one character "A". See sample data for UGENE-6581.

          Show
          Olga Golosova
          added a comment - - edited The feature works properly, the problems happened because of another reason - a sequence contain only one character "A". See sample data for UGENE-6581 .

            People

            • Assignee:
              Unassigned
              Reporter:
              Olga Golosova
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile